GCF-Board

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!

GCF-Board » Linux, Unix, BSD » Geforce 5200 Suse 8.2 prof : 3d bzw. Treiber » Threadansicht

Autor Thread - Seiten: -1-
000
21.10.2003, 20:21 Uhr
nautsch

Foren Schüler


Hallo.

Ich habe ein Suse 8.2 Prof bei mir laufen und ne Geforce fx5200 in der Kiste (bitte nichts von wegen: boah is die Karte scheiße) Ich möchte nun gern die 3d unterstützung der Karte aktivieren (Dabei ist mir eigentlich egal, daß die Karte nicht als NVidia Geforce fx5200 erkannt wird sondern als NVidia 0x0322.). Aber jedesmal, wenn ich das tue, bekomme ich einen schwarzen bildschirm beim von SaX durchgeführten Test der Einstellungen.

ich habe mir neue Treiber von NVidia geholt und installiert.
mit switch2nvidia angewendet, weil es ja über SaX nicht ging und bis dato der von Xfre86 (nv) verwendet wurde.
Ergebnis --> schwarzer Bildschirm. schlecht.

Übrigens, wenn der Bildschirm schwarz wird, dann stürzt der Rechner ab. Das heisst ich kann nicht merh in eine Konsole wechseln, noch sonst irgendwas machen. Er scheint aber nicht ganz tot zu sein, weil er auf ein STRG + ALT + ENTF mit einem "blip blup" (kurzes hohes gefolgt von kurzem tiefen piepen) reagiert, allerdings auch nur einmal. Danach darf ich den Reset Knopf bemühen.

Also kann mir hier jemand helfen? ich hab mir nen Wolf gegoogled und nix wirklich passendes gefunden (naja bei der Treiberinstallation hats schongeholfen das klappt ja nu auch)

falls benötigt:
Athlon XP 2400+
Mainboard Asrock K7s8x
suse 8.2 prof
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!

Dieser Post wurde am 21.10.2003 um 20:35 Uhr von nautsch editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
22.10.2003, 02:29 Uhr
Viego|GCF

Foren Geselle


benutzt du die nvidia treiber ?
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
22.10.2003, 12:22 Uhr
nautsch

Foren Schüler


Wie gesagt. Ich möchte sie benutzen. geht allerdings nicht. Es wird immernoch der Treiber von Xfree86 verwendet (nv) und nicht der von nvidia (nvidia), wenn ich zu diesem umschalte erhalte ich das genannte schwarze Bild (wenn der X Server gestartet wird) und der Rechner stirbt.
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!

Dieser Post wurde am 22.10.2003 um 12:23 Uhr von nautsch editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
22.10.2003, 18:11 Uhr
Viego

Foren Schüler


Ich geh mal davon aus dass du die Readme gelesen hast. Du musste neben dem install script noch 2,3 Zeilen in der XF86Config ändern Zudem würde ich mal die Herzzahl des Monitors kontrollieren
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
22.10.2003, 18:22 Uhr
nautsch

Foren Schüler


Dann hab ich sie irgendwie nich gelesen. was soll ich denn da ändern. überall steht, daß ich den installer mit "sh NVIDIA..." ausführen soll. nun musste ich die Variable IGNORE_CC_MISMATCH auf yes setzen, weil er nich raffen wollte, daß der Kernel genau mit dem gcc kompiliert wurde, wie er dieses Modul kompilieren wollte. is dann ja auch alles gelaufen.

So: was genau muss da geändert werden? und der monitor sollte keine zicken machen. läuft glaub ich auf 65 Hertz @ 75 oder so. das steht jedenfalls im SaX.

Danke für die Hilfe im vorraus
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
22.10.2003, 18:37 Uhr
outaspace
Schinder No. 1

Moderator
Foren Champion



Zitat:
läuft glaub ich auf 65 Hertz @ 75 oder so


wie jetzt? 65 oder 75 Hertz?
65 wär schon ne extrem komische einstellung, und die zeilen die du ändern musst stehen wie viego schon sagte in der _Readme_
--
Ich kann auch ohne Spaß Alkohol haben.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
23.10.2003, 00:54 Uhr
nautsch

Foren Schüler


So. hab gewurschtelt und nu n neues prob dazu.

Beim booten mit den nvidia treibern bekomme ich n schwarzes Bild. Kann mich jedoch per ssh von nem anderen rechner aus einloggen. mittels killall -9 X den X server beenden. wenn ich ihn danach starte läuft er einwandfrei mit 3d und allem. Auch wenn ich in runlevel 3 boote und den x von hand starte, klappts erst beim 2ten mal. Nu bin ich vollends verwirrt. Aber ich weiss jetzt daß es nich am Bildschirm liegt, weil es geht ja.
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
23.10.2003, 21:05 Uhr
Viego

Foren Schüler


in der redame steht was bzgl modulen die nicht geladen werden sollen ... ich schau mal bei nvidia und überall steht hass ich ja schon grad ...
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
23.10.2003, 21:10 Uhr
Viego

Foren Schüler



Zitat:


(Abschnitt 03) EDITIEREN IHRER XF86CONFIG-DATEI
__________________________________________________________________________

Bei der Einführung von Xfree86 4.0 verwendete diese eine geringfügig andere
XF86Config-Dateisyntax als die Version 3. Damit die Versionen 3.x und 4.x
von XFree86 gleichzeitig auf dem System bestehen können, wurde entschieden,
dass XFree86 4.x die Konfigurationsdatei "/etc/X11/XF86Config-4" verwendet,
wenn diese existiert, und nur wenn diese nicht existiert, die Datei
"/etc/X11/XF86Config" (dies ist eines starke Vereinfachung der Kriterien,
bitte lesen Sie die XF86Config-Manpage, um eine vollständige Beschreibung
des Suchpfades zu erhalten). Bitte achten Sie darauf, dass Sie wissen,
welche Konfigurationsdatei XFree86 verwendet. Wenn Sie sich nicht
sicher sind, schauen Sie in Ihrer Xfree86-Logfile
("/var/log/XFree86.0.log") nach einer Zeile, die mit "(==) Using config
file:" beginnt. Diese README verwendet unabhängig von dem tatsächlichen
Namen die Bezeichnung "XF86Config" für Ihre Konfigurationsdatei.

Wenn Sie nicht über eine funktionierende XF86Config-Datei verfügen, gibt es
mehrere Möglichkeiten. Sowohl mit XFree86 als auch mit dem NVIDIA-
Treiberpaket wird jeweils eine Beispiel-Konfigurationsdatei ausgeliefert
(die NVIDIA-Version wird in /usr/share/doc/NVIDIA_GLX-1.0/ installiert).
Sie können darüber hinaus ein Programm wie 'xf86config' verwenden; einige
Distributionen haben auch ein eigenes Tool zum Erzeugen einer XF86Config-
Datei. Weitere Informationen über die XF86Config-Dateisyntax erhalten Sie
auf der entsprechenden Manpage.

Wenn Sie bereits über eine XF86Config-Datei verfügen, die einen anderen
Treiber verwenden (wie z. B. den 'nv'- oder 'vesa'-Treiber), müssen Sie
lediglich den entsprechenden Abschnitt 'Device' finden und die Zeile:

Driver "nv"
(oder Driver "vesa")

durch

Driver "nvidia"

ersetzen.

Im Abschnitt 'Module' muss Folgendes erscheinen:

Load "glx"

Die folgenden Zeilen sollten ebenfalls entfernt werden:

Load "dri"
Load "GLcore"

(vorausgesetzt, sie existieren). Es gibt viele Optionen, die der
XF86Config-Datei hinzugefügt werden können, um Feineinstellungen
vorzunehmen. Eine vollständige Liste dieser Optionen finden Sie in
Anhang D.

Sobald Sie Ihre XFConfig-Datei konfiguriert haben, können Sie X neu starten
und die beschleunigten OpenGL-Bibliotheken nutzen. Nachdem Sie X neu
gestartet haben, sollten Sie jede OpenGL-Anwendung starten und automatisch
mit den neuen NVIDIA-Bibliotheken nutzen können. Hinweise zur
Problembeseitigung finden Sie weiter unten im Abschnitt
"FAQs - HÄUFIG GESTELLTE FRAGEN".

__________________________________________________________________________



Dieser Post wurde am 23.10.2003 um 21:10 Uhr von Viego editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
24.10.2003, 15:44 Uhr
nautsch

Foren Schüler


Ist alles so eingestellt. eine XF86Config-4 gibt es nicht, allerings eine mit mit meinem usernamen dahinter. in der ist allerings auch alles Ok. Ich hab in nem anderen Forum gelesen, daß einer das Problem gelöst hat indem er in das Startscript des X-Servers:
sleep 10;
killall -9 X;
eingetragen hat. gut damit sollte es gehen, aber es muss doch ne Möglichkeit geben, den Serve beim ersten mal richtig zu starten.

In der FAQ der readme ist dieses Problem nicht beschrieben.
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
24.10.2003, 15:50 Uhr
nautsch

Foren Schüler


ich habs bei mir jetzt einfach auch so gemacht. also die beiden Zeilen in die xdm eingefügt und es geht. aber auf dauer find ich ist das keine Lösung, den X jedesmal abzuschiessen und neu zu starten.
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
011
29.10.2003, 16:33 Uhr
nautsch

Foren Schüler


weiss keiner was?
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
012
29.10.2003, 21:16 Uhr
Deadalus Node

Foren Geselle


Der X-Server sollte die Konfigurationdatei nehmen die in /etc liegt - /etc/XF86config . X ist X. Er nimmt imemr die selbe Konfigdatei - es sei denn du sagst ihm das er eine andere nehmen soll, und per default ist das eben /etc/XF86config .
Ansonsten schau mal nach welche Konfigdatei dein X-Server nimmt


Quellcode:

cat /var/log/XFree86.0.log | grep Using
(==) Using config file: "/etc/XF86Config"



Meinen X-Server schiess ich ja auch nicht immer ab. Benutze ja auch die nvidea Treiber.

[smilies gekillt]

Dieser Post wurde am 30.10.2003 um 08:59 Uhr von ToP-PaPPa editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
013
29.10.2003, 21:22 Uhr
nautsch

Foren Schüler


Der X-Server sucht eine konfig Datei beim starten. Er hat eine bestimmte Reihenfolge und je nachdem welche er zuerst findet, die nimmt er. Aber was hat das mit meinem Problem zu tun? Oder meinst du ich habe die falsche editiert? hmm ich guck das mal nach. Gib mir 10 Minuten.
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
014
29.10.2003, 21:31 Uhr
nautsch

Foren Schüler


er benutzt die /etc/X11/XF86Config und die ist richtig konfiguriert.

hmm. wenn das wieder an diesem scheiß Mainboard liegt krieg ich die Krise. Ich hab mir dieses Asrock ding geholt, weils günstig war. Wer rechnet denn mit einer derartigen Inkompatibilität? Mein Gamepad geht auch schon nich richtig. Aber egal.

Bin immernoch für alles offen, was helfen könnte
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
015
30.10.2003, 19:26 Uhr
Deadalus Node

Foren Geselle


Wenn du die Konfigdatei ediiert hast und er sie verwendet wuerde es funktionieren.
Schau mal in deine Logs ob der X-Server eine fehlermeldung ausspuckt (beim ersten Start - nicht nachdem du ihn gekillt und neu gestartet hast)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
016
31.10.2003, 12:01 Uhr
Deadalus Node

Foren Geselle


ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4496/NVIDIA_GLX-1.0-4496.src.rpm
ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4496/NVIDIA_kernel-1.0-4496.src.rpm

Die installierst du via "rpm --rebuild", wechselst dann nach "/usr/src/packages/RPMS/" und installierst beide Packages ganz einfach mit "rpm -i PACKAGENAME".

Damit stimmt es 100% mit deinem Kernel ueberein. (Hab es eben selber mal mit den *rpm versucht, und das selbe ergebnis wie du gehabt). Dann ueberpruefst du noch mal ob du in deiner XF86Config alles richtig eingetragen hast. Dann _muss_ es gehen.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
017
01.11.2003, 18:43 Uhr
nautsch

Foren Schüler


hmm. werd ich von mir aus probieren.

Aber warum sollte denn die *.run Datei von NVidia nicht funktionieren? ich habe das nicht mit nem prm installiert sondern mit den aktuellen nvidia treibern und das ist nur noch eine Datei und zwar: NVIDIA-Linux-x86-1.0-4496-pkg2.run. diese ruft man mit sh NVIDIA-Linux-x86-1.0-4496-pkg2.run auf und der installiert sich dann recht gut alleine wenn man ihm vorher ein "export IGNORE_CC_MISMATCH=yes" mitgibt (Ich habe das gemacht weil der installer meinte der Kernel sein mit einer anderen gcc version compiliert worden, als die die installiert ist, was nicht der fall ist). Aber ich werds mal versuchen. (nicht vor Montag, weil ich nich zuhause bin)
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!

Dieser Post wurde am 01.11.2003 um 18:44 Uhr von nautsch editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
018
01.11.2003, 19:54 Uhr
Deadalus Node

Foren Geselle


Wahrscheinlich gibt es ein Problem mit den Modulen, wenn sie fuer einen anderen Kernel kompiliert sind. Dadurch ist das Modul fuer eine anderen Kernel gebacken, und laed sich dann nicht korrekt ein.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
019
02.11.2003, 22:51 Uhr
nautsch

Foren Schüler


Ich war mal so schlau und hab im nvidia forum geguckt. (hätt ich auch früher drauf kommen können) da stand man solle doch als option "NvAGP" "0" in die config datei einfügen. und siehe da es geht. ich hab zwar keinen schimmer warum , aber es geht. Trotzdem Danke für die viele Hilfe und wer weiss was das mit dem "NvAGP" "0" auf sich hat kan mir das gerne mitteilen. ich würd denn doch gern wissen, was mein system macht.

nautsch
--
Woher soll ich wissen was ich denke, bevor ich höre was ich sage?!
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ Linux, Unix, BSD ]  



German Computer Freaks

powered by ThWboard 3 Beta 2.85-rc3
© by Paul Baecher & Felix Gonschorek