GCF-Board

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!

GCF-Board » Linux, Unix, BSD » Festplatte unter Suse 9.0 mounten » Threadansicht

Autor Thread - Seiten: -1-
000
30.11.2003, 20:26 Uhr
BleedingSoul

Foren Schüler


Ich wollte in meinen Suse - Rechner eine zweite Festplatte einbauen um mir ein Paar Daten zu überspielen. Allerdings kann ich nicht darauf zugreifen.
Hab versucht selbst die Platte als hdb in fstab einzutragen. Hab auch versucht sie mit dem mount Befehl in mein Homeverzeichnis zu mounten.
Es hat nicht geklappt.
Wie mount ich die Festplatte richtig? Sie hat NTFS als Dateisystem.
Spielt die Größe eine Rolle? Sie ist 80 GB groß.
Hoffentlich kann mir jemand helfen, sonst kann ich weiter googlen.

mfg
BleedingSoul
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
30.11.2003, 20:48 Uhr
ToP-PaPPa
Der, der den Hammer schwingt
Foren Papst


ntfs-support im kernel einkompiliert bzw als modul verfügbar?

ausreichen sollte
mount /dev/hdb /existierendesLeeresVerzeichnis
--
If minds had anuses, blogging would be what your mind would do when it had to take a dump.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
30.11.2003, 21:41 Uhr
BleedingSoul

Foren Schüler


Ist Suse 9.0. Die NTFS Unterstützung ist also im Kernel enthalten, denk ich mal. Auf meiner Linux-Festplatte ist ja auch eine NTFS- Partition. Darauf kann ich auch zugreifen.
Hab versucht mit mount /dev/hdb /home/festplatte das Ding in mein Homeverzeichnis zu mounten. Das festplatte - Verzeichnis hab ich vorher erstellt. Tut sich aber nix.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
30.11.2003, 22:41 Uhr
BleedingSoul

Foren Schüler


Hab ich vergessen zu erwähnen: beim mounten kommt immer die Fehlermeldung: can't read superblock
Was ist der superblock? Hat das was mit dem MBR zu tun?
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
30.11.2003, 23:22 Uhr
Deadalus Node

Foren Geselle


Du must die Partition angeben nicht nur die Festplatte.

/dev/hda - Primary Master
/dev/hdb - Primary Slave
/dev/hda1 - erste Parition auf Primary Master
/dev/hda2 - zweite Parittion auf Primary Master
/dev/hdb3 - dritte Parition auf Primary Slave
/dev/hdc4 - vierte Partition auf Secondary Master usw

Dieser Post wurde am 30.11.2003 um 23:26 Uhr von Deadalus Node editiert.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
01.12.2003, 19:43 Uhr
BleedingSoul

Foren Schüler


Hab's jetzt so gemacht. Bei hda geht was, aber wenn ich versuche hdb1 oder hdb2 usw. zu mounten kommt immer nur die Meldung
"can't read superblock" und das war's. Hab auch noch zwei andere Festplatten mit anderen Dateiformaten eingebaut. Immer die selbe Meldung.
Was tun?

mfg BleedingSoul
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
01.12.2003, 22:18 Uhr
Deadalus Node

Foren Geselle


Das richtige Dateisystem angeben? man mount(8)
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
01.12.2003, 22:24 Uhr
BleedingSoul

Foren Schüler


Hab mount -t ntfs /dev/hdb1 /home/festplatte eingegeben.
Dann hab ich ne Festplatte eingebaut wo ich Linux Mandrake 9.1 installiert hab. mount -t ext2 /dev/hdb1 /home/festplatte.
Wieder can't read superblock.
Du hast Recht. Ich muss mehr man-pages lesen. Irgendwas mach ich falsch.

mfg
BleedingSoul
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
02.12.2003, 09:06 Uhr
ToP-PaPPa
Der, der den Hammer schwingt
Foren Papst


ist die platte vielleicht doch auf hdc?
--
If minds had anuses, blogging would be what your mind would do when it had to take a dump.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
02.12.2003, 15:25 Uhr
BleedingSoul

Foren Schüler


Wenn ich mount -t ntfs /dev/hdc1 /home/festplatte eingebe, kommt die Meldung:
" dev/hdc1 ist kein gültiges blockorientiertes Gerät". Hängt also an hdb.

mfg BleedingSoul
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
02.12.2003, 15:39 Uhr
AzRaD
Besserwisser reloaded
Foren Champion


Aber die Festplatte ist schon richtig im Bios eingerichtet, ja?
--
Build a system that even a fool can use and only a fool will use it.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
011
02.12.2003, 16:03 Uhr
ToP-PaPPa
Der, der den Hammer schwingt
Foren Papst


was sagt den das system beim booten wo platten hängen? mach mal als root

Quellcode:

cat /var/log/dmesg | grep /dev/hd


--
If minds had anuses, blogging would be what your mind would do when it had to take a dump.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
012
02.12.2003, 17:01 Uhr
BleedingSoul

Foren Schüler


@AzRaD
Ja, da bin ich mir eigentlich sicher dass das Bios die Platte richtig erkannt hat, ich werd's aber sicherheitshalber mal checken.

Da kommt das:
linux:~ # cat /var/log/dmesg | grep /dev/hd
cat: /var/log/dmesg: No such file or directory
linux:~ #


Mal ne Frage: Unter /var/log/warn steht das:
Dec 2 17:02:38 linux modprobe: modprobe: Can't locate module ide-disk

Da stimmt was nicht, wieso kann er die Platte nicht localisieren?Liegt es daran?
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
013
02.12.2003, 17:48 Uhr
BleedingSoul

Foren Schüler


OK. das war's, jetzt gehts endlich.
Der Fehler ist das unter /boot/grub/menu.lst steht hdb=ide-scsi:


###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
kernel (hd0,3)/boot/vmlinuz root=/dev/hda4 vga=0x31a splash=silent desktop hdb=ide-scsi hdblun=0 showopts
initrd (hd0,3)/boot/initrd

Das scsi muss raus, da es ja keine scsi-Platte ist. Hab's gelöscht und das mounten ging ohne Probleme (mach drei Tagen). Linux ist ganz schön komplex.

Und danke für eure Antworten.

mfg BleedingSoul
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
014
02.12.2003, 21:50 Uhr
Deadalus Node

Foren Geselle


Spielt auch keine Rolle ob es ein SCSI System ist - das ist nur eine Kernelemulation - wichtig spaeter wenn du CD's brennen willst.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ Linux, Unix, BSD ]  



German Computer Freaks

powered by ThWboard 3 Beta 2.85-rc3
© by Paul Baecher & Felix Gonschorek