GCF-Board

Registrieren || Einloggen || Hilfe/FAQ || Suche || Memberlist || Home || Statistik || Kalender || Staff Willkommen Gast!

GCF-Board » Linux, Unix, BSD » Gag Bootloader --> Debian bootet nimma! » Threadansicht

Autor Thread - Seiten: -1-
000
03.03.2005, 09:06 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Guten Morgen euch allen!

Ich hab' da jetzt folgendes Problem und hoffe, dass mir jemand einen Tipp geben kann, ich es lösen kann.

Folgendes:
Ich hab auf meinem Notebook 2 OS laufen:
Windoz ME (ja ich weiß...) und Debian Woody.
Bis gestern hab ich die Mühle immer mit Lilo gebootet und es hat gut funktioniert. Was mich daran gestört hat, war nur, dass ich Lilo nach einer gewissen Zeit das Standard-OS von selbst bootet und jeder die Maschine einschalten kann.

Deswegen hab ich jetzt den GAG-Bootloader (mit dem ich bisher gute Erfahrungen hatte) installiert. Ich mag die Software einfach. Wer's kennt, wird wissen warum.
Ich hab' im Bootmenü von GAG beide System angelegt, gut.

Windows ME bootet nach wie vor (läuft ja jetzt gerade), aber Debian bootet nicht mehr.

Da ich ja auf Linux ein Newbie bin, weiß ich jetzt nicht, was ich da genau ruiniert habe.
Wenn meine Theorie stimmt, dann hat der GAG den MBR überschrieben, wo bis jetzt ja LILO lag, oder??

Die Rescue, Root und Floppy Disks von Debian hab ich noch, aber ob's was hilft, oder was genau ich machen muss, weiß ich jetzt ehrlich gesagt auch nicht!

Wäre nett, wenn mir jemand einen Tip geben kann, wie ich's wieder zum Laufen bringe, da ich das Debian nicht neu aufsetzen will!

BITTE / DANKE!

(Ja, ich weiß: Never change a running system!)
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
001
03.03.2005, 09:35 Uhr
ToP-PaPPa
Der, der den Hammer schwingt
Foren Papst


1. Man kann Lilo so einstellen, dass er nicht automatisch ein OS startet
2. Man kann Lilo so einstellen, dass man ein Passwort eingeben muss.
3. Habe mir mal die Beschreibung von GAG durchgelesen, ausser dass er bunter als Lilo ist, sehe ich jetzt nicht so wirklich viele Vorteile... *G*
--
If minds had anuses, blogging would be what your mind would do when it had to take a dump.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
002
03.03.2005, 09:56 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Zu
1. -> Hab ich nicht gewusst
2. -> Hab ich auch nicht gewusst
3. -> Naja, er ist für einen Newbie wie mich leichter zu konfigurieren (Siehe Punkte oben...)

OK, ich hab' also jetzt erfahren, dass ich mein System vollkommen umsonst in den Tiefschlaf geschickt habe.

Aber gibt es auch Möglichkeiten, das OS wieder zum Booten zu bekommen??

Mit der Bitte um Hilfe und Denkanstöße,
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
003
03.03.2005, 10:40 Uhr
ToP-PaPPa
Der, der den Hammer schwingt
Foren Papst


GAG hat definifitiv LILO überschrieben. Aber solange das Debian noch auf der Platte ist, kann es auch wieder gemountet werden. Vermutet mal, GAG ist einfach nur nicht sauber geconft...
--
If minds had anuses, blogging would be what your mind would do when it had to take a dump.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
004
03.03.2005, 10:46 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Hm, soweit ich dass im GAG - Setup festellen kann, gibt es nicht viel zum configen.
Ich kann lediglich die Platte / bzw. die Partition auswählen, die gestartet werden soll und ob ich ein PWD will.
Aber dass ich eine boot-option vergeben könnte, wär mir bis jetzt nicht aufgefallen.

Ich seh mir jetzt noch mal genau an, welche Fehlermeldung er bringt, wenn ich Debian booten will und poste das dann mal.
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
005
03.03.2005, 11:29 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Also im GAG gibt es keine zusätzlichen Optionen.

Ich kann im Hauptmenü ein neues OS hinzufügen.
"83h LinuxEXT2"
Aber Optionen oder so gibt es nicht.

Wenn ich das Debian dann booten will, bekomme ich folgende Meldung:

Bootsektor nicht gefunden / korrupt.

Heul...... :-(

Wie kann ich das wieder hinbekommen?
Hilfe - Bitte / Danke!
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
006
03.03.2005, 11:44 Uhr
Nermal
Junior Schinderchen
Foren Papst


und wenn du wieder lilo installierst?
--
<Merowig> Nermal hat den Charme einer russischen Gewichtsheberin.

<teikon> aber du hast einen leichten hang zu aggressionen sowie Du-Nu zu depressionen und Nermal zu Geigen

[14:20] <t4c> Ja Nermal iss ne Frau. Weisst Du so nen Ding mit keinem Ding wo Dein Ding iss.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
007
03.03.2005, 11:48 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Ja, genau darum geht es mir.
Im Prinzip ist es mir egal welchen Bootloader ich nehme.

Ich will nur mein Debian wieder haben!!! (*heul*)

Aber wie oben erwähnt:
Da ich ein Newbie bin, bräuchte ich einen kleinen Denkanstoß, wie ich Lilo wieder draufkriege.

Z.B.:
Nimm Debian RescueDisk + ??? und installiere dann..., oder führe aus....

Eben ein Denkanstoß, wo ich anfangen soll.
Ich weiß eh, dass ich keine Step-by-Step Anleitung erhalte, aber zumindest einen Fingerzeig, denn ich auch ein wenig verwerten kann.

Bitte / Danke
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
008
03.03.2005, 11:59 Uhr
Nermal
Junior Schinderchen
Foren Papst


oh, lilo war bei dir in debian integriert? urks.. dann weiss ich es auch nicht.. gibts doch aber auch einzeln, oder?
--
<Merowig> Nermal hat den Charme einer russischen Gewichtsheberin.

<teikon> aber du hast einen leichten hang zu aggressionen sowie Du-Nu zu depressionen und Nermal zu Geigen

[14:20] <t4c> Ja Nermal iss ne Frau. Weisst Du so nen Ding mit keinem Ding wo Dein Ding iss.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
009
03.03.2005, 13:31 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


*heureka*

Also Leute:

Ich hab mich jetzt (Mittagspause fällt aus) damit noch mal beschäftigt und
kann euch folgendes berichten:

Information

Ich hab das Basesystem damals über Floppies und eine FAT32 (basedebs.tar) aufgesetzt und über FTP (tasksel) aktualisiert und meinen Bedürfnissen angepasst.
Die Floppies hatte ich aufgehoben, es waren 6 Stück.
Eine RESCUE,
eine ROOT,
und 4 x DRIVERS.

Für gewöhnlich bootet man von der RESCUE und spielt dann
ein kleines Root-System über die ROOT - Floppy ein.
Die Driver - Disks sind eh selbsterklärend.

Gut.

Ich hab jetzt die RESCUE Floppy ins Laufwerk gepackt und davon gebootet.
Über die README der Floppy habe ich erfahren, wie's funktionieren soll.

Also:

bootprompt: rescue root=/dev/hdaX (wobei X für die jeweilige Partition steht - bei mir war es /dev/hda6)

Nach einem ENTER passiert einiges, dass ich ehrlich gesagt nich nachvollziehen kann, da es a) zu schnell ging und b) ich vieles noch nicht verstehe.

Naja, jedenfalls ist bald wieder mein geliebter Gnome am Bildschirm erschienen.
Ich hab dann Lilo-Config gemacht, das Teil wieder in den MBA geschrieben (die Optionen waren eh noch in der Lilo.config)
und neu gestartet. Tja, und da war mein LILO wieder! Hurrah!

Jetzt möchte ich nur noch wissen, wie man die (oben von ToP-PaPPa erwähnten) Einstellungen vornimmt, damit ich

1) es so einstellen kann, dass NICHT automatisch ein OS gebootet wird
und
2) das ganze über ein PWD geschützt ist.

Mit der Bitte um einen Fingerzeig,

Bitte / Danke.
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
010
03.03.2005, 13:34 Uhr
outaspace
Schinder No. 1

Moderator
Foren Champion


man lilo.conf && vi /etc/lilo.conf

*fingerzeig*
--
Ich kann auch ohne Spaß Alkohol haben.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
011
03.03.2005, 14:39 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Danke, kenn mich schon aus... :)

Hat auch funktioniert. Zumindest so halbwegs...
Ich bekomme das mit dem Passwort jetzt hin. Cooooool!
Nur mit dem Timeout, bzw. der Einstellung, dass es NICHT automatisch bootet, häng ich noch ein wenig, da es nix bringt, wenn ich
z.B. 0 eingebe.
Wenn ich dann eine GROSSE Zahl eingebe, nützt es auch nix, weil es ja nicht das ist, was ich möchte.

Ich hab jetzt ja Panik, dass das System dann wieder nicht bootet, wenn ich in der Config zu viel herumdoktore.

Aber erstmal danke für die Hilfe/Fingerzeig.
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
012
03.03.2005, 15:58 Uhr
outaspace
Schinder No. 1

Moderator
Foren Champion


könntest mal versuchen die option timeout=** ganz zu entfernen, könnte helfen. Bin mir aber nicht sicher
--
Ich kann auch ohne Spaß Alkohol haben.
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
013
03.03.2005, 16:17 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Also, in der Config steht, dass man nach Änderungen der lilo.conf das Programm lilo starten soll, damit der die Änderungen übernimmt.

Wenn ich jetzt timeout =
leer lasse, crasht lilo!

Wenn ich 0 (null) schreibe, bootet er logischerweise sofort.
Ich könnte mal versuchen, timeout mit # auszukommentieren, aber
ob das funzt?

Ich werd's mal probieren und mich dann melden.
Sollte in der Zwischezeit jemand ne Idee haben, bin
ich natürlich wie immer dankbar!
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
014
03.03.2005, 16:33 Uhr
bembulak
BAU
(Bester anzunehmender User)
Foren Azubi


Ok, man muss die Zeile Timeout auskommentieren (#) dann geht's.

Yippie,

euch allen vielen dank für die "Fingerzeigs"!
--
.: BEMBU :.
[img]http://bembulak.bas-x.de/images/cthulu.jpg[/img]
"Nun sieh mal, was du mich hast anrichten lassen, du Halunkenhase!"
Seitenanfang Seitenende
Profil || Private Message || Suche Zitatantwort || Editieren || Löschen || IP
Seiten: -1-     [ Linux, Unix, BSD ]  



German Computer Freaks

powered by ThWboard 3 Beta 2.85-rc3
© by Paul Baecher & Felix Gonschorek